
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Module 4: Schematic Capture 
 
 

 

 

  



 

Module 4: Schematic Capture 

4.1 Introduction to Schematic Capture................................................. 4-1 

4.2 The Schematic Editor workspace ................................................... 4-2 
4.2.1 Document Options..........................................................................................4-2 
4.2.2 Preferences ....................................................................................................4-8 

4.3 Libraries and components............................................................... 4-9 
4.3.1 Locating and loading libraries ........................................................................4-9 
4.3.2 Locating components ...................................................................................4-11 
4.3.3 Browsing libraries .........................................................................................4-13 
4.3.4 Exercises – Libraries and components ........................................................4-14 

4.4 Placing and wiring.......................................................................... 4-17 
4.4.1 Placing components .....................................................................................4-17 
4.4.2 Pin-to-pin wiring............................................................................................4-18 
4.4.3 Exercise – Drawing the schematic ...............................................................4-19 
4.4.4 Exercise – The Sensor schematic................................................................4-21 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Software, documentation and related materials:  

Copyright © 2009 Altium Limited. 

All rights reserved. You are permitted to print this document provided that (1) the use of such is for personal use only and will 
not be copied or posted on any network computer or broadcast in any media, and (2) no modifications of the document is 
made. Unauthorized duplication, in whole or part, of this document by any means, mechanical or electronic, including 
translation into another language, except for brief excerpts in published reviews, is prohibited without the express written 
permission of Altium Limited. Unauthorized duplication of this work may also be prohibited by local statute. Violators may be 
subject to both criminal and civil penalties, including fines and/or imprisonment. Altium, Altium Designer, Board Insight, Design 
Explorer, DXP, LiveDesign, NanoBoard, NanoTalk, P-CAD, SimCode, Situs, TASKING, and Topological Autorouting and their 
respective logos are trademarks or registered trademarks of Altium Limited or its subsidiaries. All other registered or 
unregistered trademarks referenced herein are the property of their respective owners and no trademark rights to the same are 
claimed. 

Module Seq = 4 



4.1  Introduction to Schematic Capture 
The Schematic Capture training session covers how to create single sheet schematics and multi-
sheet hierarchical projects from initial setup through to component placement, wiring, design 
verification and printing. The functionality of the Schematic Editor will be explored and a series of 
exercises will show you how to capture a design as a schematic, ready for PCB design. 

Figure 1

Figure 1. The Altium Designer schematic capture workflow 

 outlines the workflow to be followed when creating a schematic in Altium Designer.   
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4.2  The Schematic Editor workspace 
This section describes how to set up and browse the Schematic Editor workspace, done via the 
Document Options and Preferences dialogs. Sheet options, such as grids and templates, as well 
as preferences and defaults can be set through these dialogs.  

To open the Schematic Editor, simply create a new schematic document (File » New » 
Schematic) or open an existing .SchDoc document in Altium Designer. 

4.2.1 Document Options 
The Document Options dialog allows you to: 

• Set parameters relating to individual schematic files. 
• The settings in this dialog are saved with that schematic file.   
• The Document Options dialog is displayed by double-clicking on the sheet border, or by 

choosing the Design » Document Options menu command.  
The tabs of the Document Options dialog are described in the following sections. 

4.2.1.1 Sheet Options tab 
The Sheet Options tab of the Document Options dialog is shown in Figure 2. The options in 
each of the sections are explained below. 

  

Figure 2. Sheet Options tab of the Document Options dialog 
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Template section 
Displays the filename of the associated template, if any. Use the Template options in the 
Design menu to apply, update or remove the associated template. Set the default template in 
the DXP »  Preferences »  Schematic »  General. 

 
Figure 3. Setting a default template to use when creating a new schematic. 

Options section 

Orientation  

Sets the sheet orientation to Landscape or Portrait. 

Title Block 

When checked, a standard title block is attached to the sheet. The format of that title block is set 
using the drop-down list next to this option. Note that this is typically only used when there is no 
associated template. 

Show Reference Zones 

When checked, the sheet has a reference grid defined in its border. A new option has also been 
added to have the zoning as per ASME Y14.1 standard. 

Show Border  

When checked the sheet border is displayed. 

Show Template Graphics 

When checked, any objects placed in the template file defined for the sheet will be displayed in 
the sheet. This is typically used to display a non-standard title block, in which case you would 
uncheck the Title Block option. 

Border Color 

Allows you to set the border color from the Choose Color dialog. 

Sheet Color 

Allows you to set the background color of the sheet. 

Standard Style section  
Allows you to select the size of the sheet from a number of standard sizes e.g. A4, A3. 

Custom Style section 
Allows you to define a custom sheet size and border. Use this option if you want a sheet size not 
covered in the Standard Style section. 

Change System Font 
This button allows you to change the font used to display pin numbers, pin names, port text, 
power port text and sheet border text. 

Grids section 

Grids Options allow you to set the size and turn on or off the Snap Grid and the Visible Grid. 
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SnapOn 

The Snap Grid forces the mouse click location to the closest snap grid point. The Snap Grid is 
set and can be turned on or off in the Document Options dialog. You can also cycle though three 
predefined grids by pressing the G shortcut key at any time. 

Visible 

The Visible Grid displays a grid when turned on. This is independent of the Snap Grid. The 
Visible Grid can also be turned on or off in the View menu (VV). 

Electrical Grid section 

The Electrical Grid can be turned on or off and the Electrical Grid Range can be set in the 
Document Options dialog. It can also be turned on or off in the View menu (VE). 

When the Electrical Grid is turned on and you are executing a command that supports the 
electrical grid, the cursor overrides the Snap Grid and jumps to key points on objects.  

For example, if you are using the Place » Wire command and move the cursor to a certain 
distance within the Electrical Grid Range of a pin, the cursor will jump to the pin. 

4.2.1.2 Parameters tab 
The Parameters tab is used as a convenient method of editing sheet-level text. Each parameter 
is automatically linked to a text string on the sheet, where the text string is the same as the 
parameter name, except that it is preceded by an equals sign.  

For example, the Parameter Address1 is automatically linked to the text string =Address1. The 
equals sign is an instruction to the schematic editor to automatically replace the text string on the 
sheet with the value of a parameter with a name of Address1. Any number of these parameters 
can be added to a document, either a schematic template or a schematic sheet. Using these 
special strings allows template text properties, such as font, size and color, to be predefined in 
the template, while the actual text string value is defined when that template is applied to a 
schematic. 

This replacement occurs automatically during printing, it can also be performed on screen by 
enabling the Convert Special Strings option in the Graphical Editing tab of the Preferences 
dialog (Tools » Schematic Preferences). 
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Figure 4. Parameters tab of the Document Options dialog 
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The default special strings are listed in the table below, but you can create custom parameters to 
suit your document and design requirements. 

Special String Description Special String Description 

=Address1 Line of an address =Engineer Engineer’s name 

=Address2 Line of an address =ImagePath Path to image file 

=Address3 Line of an address =Modified Date Computer system date of 
last modification to file (value 
entered automatically) 

=Address4 Line of an address =Organization Organization name 

=ApprovedBy Approver’s name =Revision Revision number 

=Author Author’s name =Rule Rule description if added 
using Add as Rule option 

=Checked By Checker’s name =SheetNumber Schematic sheet number 

=CompanyName Company name =SheetTotal Total number of sheets in 
the project 

=CurrentDate Computer system date 
(value entered automatically) 

=Time Time (not automatically 
updated) 

=CurrentTime Computer system time 
(value entered automatically) 

=Title Title of schematic sheet 

=Date Date (not automatically 
updated) 

=Engineer Engineer’s name 

=DocumentFullPath 
AndName 

Filename with full path of the 
schematic sheet (value 
entered automatically) 

=ImagePath Path to image file 

=DocumentName Filename without the path 
(value entered automatically) 

=Modified Date Computer system date of 
last modification to file (value 
entered automatically) 

=DocumentNumber Document number   

=DrawnBy Draftsperson’s name   

Table 1. List of default parameters when creating a new schematic 

Figure 5

Figure 5. Special strings in a title block, with and without the Convert Special Strings option enabled 

 shows how Special Strings are entered in a title block. Text entered as the value of a 
parameter in the Parameter tab will display where the special string is placed. The properties of 
the special strings (i.e. font, color) determine the properties of the text that is displayed. 

You place special strings by selecting Place » Text String and then pressing the TAB key. The 
Annotation dialog displays. Clicking on the down arrow in the name field lists a special string for 
each of the parameters defined. Click on the string required and place it. Special strings display 
their content when the Convert Special Strings option is selected in the Graphical Editing tab 
of the Preferences dialog (Tools » Schematic Preferences), or when the schematic is printed 
or plotted. 
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4.2.1.3 Units tab 
The Units tab allows you to define the various units used in the Schematic Editor. Grids will be a 
multiples of these units so for example, using the DXP Default Units in which each unit is equal 
to 10 mils, a Snap Grid value of 5 (or 5 units) would equate to 50 mils, 10 units = 100 mils, etc. 
when printed actual size or 1:1. 

 

Figure 6. Units tab of the Document Options dialog 

Imperial Unit System Section 

Use Imperial Unit System 

Check this option to use imperial units in your schematic(s). You will also want to specify which 
imperial units to be used (DXP defaults - 10 mil, mils, inches and auto imperial units) in the 
Imperial unit used drop down list. 

Imperial unit used 

This option is used to select from one of the available imperial units; mils, inches, DXP default 
units (10 mils) and auto imperial. If the Auto-Imperial unit is selected, the system will switch from 
mils to inches when the value is greater than 500 mils. 

Metric Unit System Section 

Use Metric Unit System 

Check this option to use metric units in your schematic(s). You will also want to specify which 
metric units to be used (millimeters, centimeters, meters, and Auto-Metric units) in the Metric unit 
used drop down list. 

Metric unit used 

This option is used to select from one of the available metric units; millimeters, centimeters, 
meters, and Auto-Metric. If the Auto-Metric unit is selected, the system will switch from 
millimeters to centimeters when the value is greater than 100 centimeters. 
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4.2.1.4 Using templates 
Standard sheet templates (*.SchDot) are supplied with Altium Designer and are accessible in 
the \Altium Designer Summer 09\Templates\folder. You can also create your own 
templates and store them anywhere. 

• Select Design » Template » Set Template File Name. This option removes any existing 
template and uses the one you choose.  

• Select Design » Template » Update. Use this command when a template is modified and 
you need to refresh the sheets which use it. 

• Select Design » Template » Remove Current Template. This option removes the template 
but retains the old sheet size from the old template. 

For each of these commands you will be prompted to indicate if the change is to apply to the 
current sheet, all open, or all in project. 

4.2.2 Preferences 
The Schematic section of the Preferences dialog allows you to set up parameters relating to the 
Schematic Editor workspace. This dialog is displayed using the Tools » Schematic 
Preferences menu command. Settings in this dialog are saved in the Altium Designer 
environment and therefore remain the same when you change active schematic documents. For 
help with the options available in the preferences, use the  button in the preferences dialog; 
then click on the option more information is required on. 
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4.3  Libraries and components 
This section explores the Altium Designer libraries and how to find schematic components within 
them. 

4.3.1 Locating and loading libraries 
The supplied components are stored within a set of Integrated Libraries. An integrated library 
includes the schematic symbols, plus it can also include all associated models, such as 
footprints, spice models, signal integrity models, and so on. Most of the supplied integrated 
libraries are manufacturer-specific.  

Integrated libraries are compiled from separate source schematic libraries, PCB footprint 
libraries, etc. The components in an integrated library cannot be edited, to change a component 
the source library is edited and recompiled to produce an updated integrated library.  

There are a number of other special purpose integrated libraries, e.g. special function simulation 
components.  

Components can also be placed directly from schematic symbol libraries if this is preferred to 
integrated libraries, and you can also place them from Protel 99 SE format schematic symbol 
libraries. 

Available components are listed in the Libraries panel. The libraries presented in this panel 
include:  

• Libraries in the active project. If the project that the currently active document belongs to 
includes any libraries, they are automatically listed.  

 

Figure 7. Available Libraries dialog, showing the project tab which is libraries in the current project 

• Installed libraries. Installed libraries are those that have been made available in the 
environment. Use this option for company libraries that are used across different projects. 
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Figure 8. Available Libraries dialog, showing the installed tab which is available to any open project. 

• Libraries found down the defined project search path. This option is particularly useful for 
accessing simulation models. Search paths are defined in the Project Options dialog. 

4.3.1.1 Adding a library to make its components available 
1. To add a library, press the 

Libraries button in the 
Libraries panel or select 
Design » Add/Remove 
Library. The Available 
Libraries dialog displays. 

2. Click on the Install button 
at the bottom of the 
Installed Tab of the dialog.  

3. Navigate to the required  
libraries directory and click 
on a library to select it. The 
library you selected will 
now be listed in the 
Installed Libraries list in 
the dialog.  

4. Click Close when you have 
installed the libraries you need

F

Note: The supplied integrated libr
 \Program Files\Altium De
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igure 9. Available Libraries dialog, use the Installed tab to install or 
aries are located in the: 
signer Summer 09\Library\ folder. 
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4.3.2 Locating components 
When the location of the library isn’t known, use the Search button in the Libraries panel or the 
Tools » Find Component menu command. The Libraries Search dialog displays. The first time 
this dialog is executed, the dialog shown in . is displayed. This initial mode is referred 
to as Simple mode. In Simple mode each searchable field has to be entered either manually or 
from a list of drop down items found within the currently installed libraries. After the field data is 
entered such as Name for example, an operator and value needs to be entered. The operator 
can be selected from a drop down list of Equals, contains, starts with and ends with. The value 
field can also be selected via a drop down of values found within the currently installed libraries 
or typed manually. 

Figure 10

Figure 10. Simple view for library search dialog 

 

Once data is entered, press the search button and a search starts. Going back to the search 
dialog and press the Advanced hyperlink button, the query string for the filter created in Simple 
mode is displayed. 

Depending on current knowledge of the query language in Altium Designer, it is recommended, 
new uses use the Simple mode and users familiar with the query language use the advanced 
mode to manually type the exact search query. 
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Figure 11. Advanced view for Search Libraries dialog 

Figure 11

Tips for finding components: 

• The search dialog uses a standard query to search the libraries – if the string you type does 
not include a query keyword it is assumed that the text is either part of the component Name 
or Description and a query is built automatically, as shown in . 

• The default search Scope is Available libraries that are those libraries currently listed in the 
Libraries panel. Change this to Libraries on path to search across all the supplied libraries. 

• Search results are presented in the Libraries panel – note that the drop down where you 
select the current library will change to Query Results. 

• If you attempt to place a component in the query results from a library that is not currently 
installed you will be asked if you wish to install that library now, you can still place without 
installing the library if you wish. 

• The search can be terminated as soon as an instance of the part is found by clicking the 

 button on the Libraries panel. 
• If your search does not produce results, check that the search path is correct. Also, try 

searching for a component you know exists in a library to check that everything is set 
correctly

.  

Note: When you are searching libraries, check 
that the Filter field at the top of the Libraries 
panel has nothing in it. If there is any thing 
other than a *, then the search results will be 
further filtered, as shown in Figure 12. 

Figure 12. Ensure that the filter field 
is clear during searching.  
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4.3.3 Browsing libraries 
The Libraries panel gives access to all components that are currently available to be placed.  

• In .  
• C

d
d
c
be placed in the active project. 
Select the Installed tab, and click 
the Install button to add libraries to 
the library list. 

• Components contained in the 
selected library are listed in the 
box below the Filter field. The Filter 
allows you to control what 
component names are listed, e.g. 
RES* will display only component 
names starting with RES. 

• You can also type directly in the list 
of components, the type-ahead 
feature will automatically jump 
through the list as you type. Press 
ESC to stop performing a type-
ahead action. 

• Clicking on the name of a 
component will: display that 
component symbol in the viewer in 
the middle of the panel, list the 
associated models below that, and 
show the selected footprint model 
below that. 

• The Place button places the 
component currently selected. 
Double-clicking on the name of a 
component also achieves this. 

• The Search button is a powerful 
searching tool, allowing you to 
search through libraries for parts. 
Clicking this button pops up the 
Libraries Search dialog.  

• If a component has several parts, the 
• You can control what columns are dis

choose Select Columns to do this. U
there is the ability to sort by a particula
are covered in more detail in the Adva

 the Panel control, bottom right, select System » Libraries
lick the Libraries button to 
isplay the Available Libraries 
ialog. This dialog displays al
omponents currently availab

l 
le to 
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Panel
sub-parts will be shown in the symbol mini-viewer. 
played in the component or model lists, right-click and 
sing this with database libraries is especially useful as 
r column like shown in Figure 14. Database libraries 
nced PCB training course. 
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Figure 1 d the sort by column feature to sort by Value. 

4.3 ries and components 

d the sort by column feature to sort by Value. 

4.3 ries and components 

4. Using a database library ann

.4 Exercises – Libra.4 Exercises – Libra

.4.1 Locating and load
 training design

4.3 ing libraries when the required library is known 
The  is a microcontroller driven temperature sensor. To install one of the supplied 

 PIC microcontroller library, complete the following steps: 

1. vate the Schematic Editor. 

2. e Libraries panel to display the Available Libraries dialog. 

3. en click the Install button and navigate to the \Program 
ium Designer Summer 09\Library\directory. This directory contains sub 
ntaining the integrated libraries supplied with Altium Designer’s Schematic 

4. ectories. Open the Microchip folder, select and add the 
er 8-Bit PIC16.IntLib.  

e Available Libraries dialog. 

6. he list of libraries at the top of the Libraries panel. The 
 in the 

. 

O t
to s
Sea

1. Click on the Search button and the Libraries Search dialog will appear. 

2. For this exercise, Advanced mode is going to be used on the Library search dialog. Click on 
the Advanced Hyperlink button. 

3. Set the Scope to Libraries on path and set the search Path to C:\Program 
Files\Altium Designer Summer 09\Library (the Include subdirectories option 
should be on). 

libraries and see if it includes a

Open a schematic document to acti

Click the Libraries button on th

Select the Installed tab of dialog, th
Files\Alt
directories co
Editor. 

Scroll down through the library dir
Microchip Microcontroll

5. Click the Close button to close th

Select this Microchip library in t
library’s contents will be displayed
library includes a PIC16C773/SO

 the box below the Filter field section. Confirm that 

4.3.4.2 Finding components when their library is unknown 
f en you will want to locate a component but do not know which library it is in, or you may want 

ee what family types are available in the libraries. To search for components, we use the 
rch button or the Tools » Find Component menu command. 
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4. The power supply in the training design uses a LM317MSTT3 adjustable regulator. To 
search the supplied libraries for a suitable device type the string LM317 in the Search field at 
the top of the dialog and click the Search button. 

5. Note that the library currently being searched is listed in the Libraries panel. Depending on 
the speed of the PC it will take a few minutes to search the entire 90,000+ components for 
the required part. 

6. The result set should include components in the ON Semi Power Mgt Voltage 
Regulator.IntLib, confirm that the LM317MSTT3 part is listed.  

7. To install this library so that component will be available later you can either right-click in the 
result list and select Add or Remove Libraries (this will simply open the Available Libraries 
dialog), or you can double-click on the component name in the list to place it (you can easily 
delete it if it is the wrong sheet), when you do the Confirm dialog will appear, giving you an 
opportunity to Install the library. 

4.3.4.3 Locating components within an open library 
1. Select the library Miscellaneous Devices.IntLib in the Libraries panel. 

This library is one of two PCB libraries installed by default when the software is installed. It 
itors, diodes, etc. 

2. Type mponents are listed. 

3. Try diode he diodes whose library 
reference starts with the string diode.  

nown 
e 

2. 
rary\Pcb\IPC-7350 Series\. 

includes a variety of discrete components, including resistors, capac

cap into the Filter field. Notice that only the capacitor-type co

 in the Filter field. The only components listed now are t

4. Now try *diode, this time components that include the word diode anywhere in their name 
or description will be listed. 

4.3.4.4 Finding footprints when their library is unk
1. Footprints can be searched for in the same way as component symbols; the only differenc

is that you need to set the Search in, in the Libraries Search dialog to Footprints before 
pressing the Search button.  

Set the Search Path to C:\Program Files\Altium Designer Summer 
09\Lib
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Figure 1

 
sistor_N.PcbLib. 

ill appear letting you 
ry. 

Wh le in the Place Part dialog, or when you type in 
a footprint name in the Footprint Model dialog, the available libraries are searched in a defined 
order. This search order is the order that the libraries are listed in the Available Libraries dialog. 
To configure the search order: 

1. Click the Libraries button in the Libraries panel to display the Available Libraries dialog. 

2. Click on the Installed tab, then in the list of Installed Libraries click to select the IPC-7352 
Chip_Resistor_N.PcbLib to highlight it, and then click the Move Up button to move it to the 
top of the list. 

3. Close the Available Libraries dialog. 

 

You now have all the components and footprints required to complete the training design. 

5. Searching for a footprint 

3. Enter the string 2012 and click Search. The search results will include a number of libraries,
including IPC-7352 Chip_Re

4. Double-click on the RESC2012N footprint in the query results, a dialog w
know that the library is not currently installed, click Yes to install the libra

 

4.3.4.5 Setting the library search order 
en you type in a component name, for examp

Note: Refer to the PDF, AR0104 Component, Model and Library Concepts article in the online 
documentation for further information on definitions, library search order and component to 
model linking. 
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4.4  Placing and wiring 
This section looks at how to place components and then wire them together. The exercise takes 
you through the creation of a complete schematic sheet. 

4.4.1 Placing components 
• To place a component, double-click on its name in the Libraries panel. 
• To edit a component’s properties before you place it, press the TAB key. The Component 

Properties dialog displays. To step through the fields in the dialog press TAB (down), or 
SHIFT+TAB (up). 

• New text will overwrite text that is selected. 
• If you set the component designator before placing the component, then subsequent 

components will be automatically designated with the next designator value. 
• You can also use the Place » Part menu command if you know the name of a component. 

When you select this command, you are prompted for the name of the component. Once you 
type the component name in, the open libraries are searched and if the component is 
located, it becomes attached to the cursor for placement.  

 

Figure 16. Place part dialog 

4.4.1.1 Auto-incrementing designators 
hen placing a W component, if the initial designator is set before placing, its designator will be 

assigned by incrementing the designator of the last component placed. This will only occur for 
subsequent parts placed after the TAB key was pressed to assign the initial designator. Once you 
stop placing this type of part, the next designator in the sequence is no longer remembered. 
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Generally it is easier to leave the annotation of designators until the design is complete to allow 
the designators to be assigned in a logical and controlled manner on each sheet. Annotation is 

roject. 

4.4.2 Pin-to-pin wiring 

covered in detail later in Module 6 - Building the P

• Wires are used to create an electrical connection between points. 
• Be careful to use Place » Wire and not place lines by mistake. 
• Press ire placement mode. Press SPACEBAR to toggle 

• ted 
 must touch on the hot end of a pin to connect to it. 

oup of related signals, such as a data bus, are 
ntries. 

• Figure 20, and 

• 
• ), 

elease the CTRL key once you 
start dragging). Press the SPACEBAR or SHIFT+SPACEBAR while dragging to change the wiring 
mode. Press the M shortcut to drag a selection. 

• If you are having trouble seeing the grid in schematic goto Tools » Schematic Preferences 
» Schematic » Grids and change the Grid Color to one that is not so white. 

SHIFT+SPACEBAR to change the w
between start and end corner modes. 

• Press BACKSPACE to delete the last vertex placed. 
A point on a wire must touch on the connection point of an electrical object to be connec
to it, e.g. the wire

• Use buses to graphically represent how a gr
connected on a sheet. Also, use buses to connect related signals to ports and sheet e
Buses must use the bus name / bus element referencing system as shown in 
must include the individual net labels and the bus net label.  
The bus range can increment [0..7], or decrement [7..0]. 
To move a component on the schematic and maintain the wiring (referred to as dragging
hold the CTRL key as you click, hold and move the mouse (r

 
Figure 17. Grids setting in preferences 
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4.4.3 Exercise – Drawing the schematic 

 
Figu

1. ted during the Module 1 - Getting Started 

erature 
Sensor.PrjPcb. 

2. Add a new schematic document to the project, to do this right-click on the project file name in 
the Projects panel and select Add New to Project » Schematic.  

3. Right-click on the new schematic sheet in the Projects panel, and select Save As from the 
context menu. Save the schematic as MCU.SchDoc in the \Program Files\Altium 
Designer Summer 09\Examples\Training\PCB Training\Temperature Sensor 
folder. 

4. Set the template for your schematic to A4.SchDot by choosing Design » Template » Set 
Template File Name and choosing the A4 size template from \Program Files\Altium 
Designer Summer 09\Templates folder. 

5. Verify that the electrical grid is on and set to 4 and that the snap grip is on and set to 10 
before placing any objects (double-click in the sheet border to open the Document Options 
dialog). 

6. Draw up the schematic shown in Figure 18 above. When placing the components, press TAB 
to define the Designator and Comment (component value) before placing the component. 

re 18. MCU schematic example 

If it is not already open, re-open the project crea
With Altium Designer, \Program Files\Altium Designer Summer 
09\Examples\Training\PCB Training\Temperature Sensor\Temp

Component Library Reference 

Microcontroller PIC16C773/SO 

Resistors Res1 

Capacitor Cap 

7. To rotate a component press the SPACEBAR, press the Y key to flip it vertically, and the X key 
to flip it horizontally. 

8. Set the Port I/O Type to match their display Style. Set the Ground Style power port net 
attribute to GND. 

9.  RB[0..7] so as to connect nets RB0 through to RB7 
into a bus.  
Set the bus name and port name to
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10. To bu ight. Copy the port and run Edit » 
Smar t labels and wires on the right 
side. On the bottom section of the dialog select expand buses for signal names. You can 
also set the wire length to suit. Note that the spacing between the wires well be as per the 
current grid setting which should be on 10 so the wires and netlabels line up to the pins of 
the component. 

ild up the nets in the bus, first create the port on the r
t Paste.  Select Ports from the left side and select ne

 

Figure 19. Smart paste dialog to create the netlabels and wires that make up the signals on a bus. 

 

 
Figure 20. Buses are defined using the referencing system shown. 
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12. 

13. ary document information in the Parameters tab of the Document Options 
dialog. Enter the title as PIC Microcontroller. Don’t worry about setting the 
sheet/Document No. at this time as there is a feature that can do this automatically over your 
whole project. 

4.4.4 Exercise – The Sensor schematic 

11. While placing the resistors and capacitors you can use the component cut wires feature to 
quickly cut into the wires rather than wiring around them. 

While placing some of the ports and power ports hold down the ctrl key and drag to extend 
the wires with the object. This can save a lot of time when getting to the wiring stage. 

Enter the necess

At this stage in the training, your Temperature Sensor project should look like Figure 21. 
However, the Sensor.SchDoc and the project libraries are not there as yet. To complete it: 

1. Create a new schematic and call it 
Sensor.schdoc if you haven’t done so 
already.  

2. Save and close the Sensor.SchDoc 
sheet. Note that this sheet is just a blank 
schematic for now. It’ll be completed later 
in the training. 

3. Also you’ll need to add the library files as 
shown in Figure 21 to the project and 
save the project PCB. 

At this point we are only going to create a 
blank sheet. In Module 15 - Schematic 
Library Editor, we will create the sensor 
sheet after creating a new component. 

The last step to complete the sensor design 
is to add the top schematic sheet which is 
done in the next module Module 5 - Multi-
Sheet Design. 

 

 

Module 4: Schematic Capture 
Figure 21. Project structure after completing the 
MCU schematic. 
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